DNS Service Issues
Incident Report for amscomp
Resolved
After monitoring the issue , we no longer see any dropped DNS requests
Posted Nov 09, 2022 - 15:27 PST
Update
We are continuing to monitor this issue.
Posted Nov 09, 2022 - 14:15 PST
Update
Our DNS provider has told us that the issue has been resolved
Posted Nov 09, 2022 - 14:06 PST
Investigating
Our domain service provider is having DNS service issues. They have informed us that, since it is affecting all customers, it is their highest priority
Posted Nov 09, 2022 - 12:06 PST
This incident affected: autoecat (Website).