Outbound COUNTERPOINT email issues
Incident Report for amscomp
Resolved
This incident has been resolved.
Posted Jul 21, 2023 - 09:24 PDT
Update
Monitoring over the past day show that emails to hotmail addresses are also now flowing properly, with no reported bounce-back emails since early yesterday morning.
Posted Jul 12, 2023 - 08:16 PDT
Update
There have been a couple of additional reports of hotmail addresses bouncing, but these seem to have been intermittent, and a subsequent resend of the invoice proved to go through without issue.

We are still monitoring the services.
Posted Jul 11, 2023 - 15:53 PDT
Monitoring
We have been notified that a fix is in place, and that outbound emails are being delivered to GMail inboxes without issue.

During a number of tests on our end, we can confirm successful receipt of COUNTERPOINT system emails.

We will continue monitor emails and to work with the service provider as needed
Posted Jul 10, 2023 - 14:49 PDT
Update
Update from our email service provider:

"We continue to develop, test and deploy improvements to improve the delivery rate to Gmail and Google WorkSpace users’ inboxes.

We continue to work with Google to help solve this and with Microsoft on the root cause of this issue.

As mentioned in our last update, Google Tech Support has recently identified a vulnerability in Microsoft SPF checking, which has allowed for a new type of spam and phishing attack. It is important to note that this affects the delivery of emails to both Google Workspace and Gmail platforms. Any downstream processing services associated with these platforms automatically become tagged and implicated. Our team is actively working to address this issue and mitigate its impact on our customers. We will provide further updates as we make progress in resolving this matter.
Kind Regards"
Posted Jul 10, 2023 - 10:53 PDT
Update
The issue has been identified by our Email service provider:

"Spammers managed to leverage the Office 365 developer network as a source to create a spam wave delivered via multiple downstream providers to attack Gmail accounts over the last few days. Some of these emails were passed through VIPRE systems to send out targeted emails towards Gmail addresses. Some of these emails passed through the VIPRE Email Security solution, resulting in a significant increase in traffic which initially impacted mail processing times. Consequently, Gmail also implemented defensive measures, classifying a number of these sources as spam to ensure they protected their users.

Google Tech Support has identified a vulnerability in Microsoft SPF checking, which allowed a new type of spam and phishing attack. Unfortunately, any downstream processing services that are in that email get automatically tagged and implicated, even though the issue is an SPF check weakness being exploited on the Office 365 platform."
Posted Jul 10, 2023 - 10:00 PDT
Identified
A fix has been implemented for Microsoft addresses, which should now be receiving emails without issue.

Gmail addresses are still assigning emails to SPAM
Posted Jul 06, 2023 - 13:00 PDT
Investigating
We have received reports of COUNTERPOINT system generated emails that are sent out through eforms being bounced back from Microsoft (outlook.com, hotmail.com, live.ca) addresses and being classified as SPAM in GMail accounts.
Posted Jul 05, 2023 - 10:19 PDT
This incident affected: E-forms Email Service.