Intermittent Connectivity Issues
Incident Report for amscomp
Postmortem

Intermittent Site Unavailability

Early Tuesday morning, we began to receive reports of outages on autoecat.com. These outages were intermittent and limited to specific customer sites. Upon review of our internal monitoring logs, we discovered a 13 minute outage overnight on Monday. Beyond this short outage, our monitors were not reporting any additional issues.

Initial problems from Tuesday morning were marked as resolved, and no more reports were received.

On Wednesday, we received a number of reports that the outages had returned and, in fact, had continued during Tuesday afternoon. Reports were, again, intermittent and localized to specific sites. Further effort was put in to discovering the underlying problem, and a similarity was discovered. All reports were being sent in from users running on a Shaw internet service.

Investigation into the issue found that one of the primary Shaw DNS servers was intermittently unresponsive. This caused the user’s PC to be unable to resolve the autoecat.com domain.

A solution was implemented to help the user’s PC cache the autoecat domain results for a longer duration that normal and this appears to have resolved the symptoms of the issue at Shaw.

Posted Dec 22, 2021 - 16:34 PST

Resolved
We have not received additional reports of this issue since implementing our patch. We have since updated the work-around with a potentially longer term solution. If you experience a browsing issue with the website, please report it to support@amscomp.com
Posted Dec 22, 2021 - 16:29 PST
Monitoring
We have implemented a fix to try and address the intermittent Shaw DNS outages and users should begin seeing more stable browsing. We will continue to monitor throughout the afternoon.
Posted Dec 22, 2021 - 10:39 PST
Identified
It appears that there is an issue with a Shaw DNS service and, as a result, some Shaw users are experiencing intermittent 'Page cannot be reached' errors.
Posted Dec 22, 2021 - 10:38 PST
Update
We are continuing to investigate this issue.
Posted Dec 22, 2021 - 09:44 PST
Investigating
We have received reports of intermittent connectivity issues with autoecat. At this time, our monitors indicate that the site is fully operational, but we are investigating if there may be an upstream issue
Posted Dec 22, 2021 - 08:42 PST
This incident affected: autoecat (Website).