Origination/Termination Issues: Various
Incident Report for amscomp
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 13:18 PDT
Monitoring
Service provider reports that services are stable as of 14:07 ET, and they are still investigating further.
Posted Dec 14, 2023 - 12:08 PST
Investigating
We are investigating reports of Origination issues in Various Regions

Please stand by for updates. We thank you for your patience and apologize for the inconvenience.
Posted Dec 14, 2023 - 11:12 PST
This incident affected: AMS VoIP Services (Hosted PBX Services, SIP Carrier Services).